WordPress ResAds 1.0.1 Cross Site Scripting

Posted on Posted in Hacker News

WordPress ResAds plugin version 1.0.1 suffers from multiple reflective cross site scripting vulnerabilities.

Vulnerability title: Multiple Reflected XSS in ResAds version 1.0.1 WordPress plugin
CVE: CVE-2015-7667
Vendor: WordPress web-mv
Product: ResAds
Affected version: 1.0.1
Fixed version: 1.0.2
Reported by: Ibéria Medeiros

Vulnerability Details:
=====================
It was discovered that no protection against multiple reflected XSS attacks was implemented, resulting in an attacker being able to retrive user data from end user, such as session cookies.

The ResAds version 1.0.1 WordPress plugin is vulnerable to 2 reflected XSS vulnerabilities.
The templates/admanagement/admanagement.php and templates/adspot/adspot.php files are vulnerable to Cross-site.scripting (XSS) attacks via $_REQUEST['page'] parameter.

System affected:
===============
Any system that access to a web site developed by WordPress CMS version 4.3.1 or earlier and uses the ResAds version 1.0.1.

Advisory:
========
https://wordpress.org/plugins/resads/changelog/

Solution:
========
Update to ResAds version 1.0.2 plugin.
https://wordpress.org/plugins/resads/

Disclosure Timeline:
===================
Vendor notification: September 27, 2015
Vendor fixed vulnerability: September 29, 2015
Public advisory: September 29, 2015
Public disclosure: October 4, 2015

Quelle: Packet storm Security

Facebooktwittergoogle_plus